Advanced Post List

Community support forum for other developers who use the plugin.


You are not connected. Please login or register

I get errors with the latest update

View previous topic View next topic Go down  Message [Page 1 of 1]

1 I get errors with the latest update on Sat Apr 14, 2012 6:48 pm

GameDemon


Hello,

I just updated to your latest version, but I get errors now:

Code:
Warning: Invalid argument supplied for foreach() in /home/simaor/domains/myanimeblog.com/public_html/wp-content/plugins/advanced-post-list/includes/class/APLCore.php on line 1466

Warning: array_unique() [function.array-unique]: The argument should be an array in /home/simaor/domains/myanimeblog.com/public_html/wp-content/plugins/advanced-post-list/includes/class/APLCore.php on line 1478

Can you please help me?

2 Re: I get errors with the latest update on Sun Apr 15, 2012 6:04 am

Admin


Admin
Sorry about the issue and thank you for posting this.

The problem seems to be showing up in the preset's post parents list. Either the variable is not an array or it isn't set. Sounds like its something in the preset backend settings.

Did you upgrade and then downgrade with any of the beta versions? ...and could you supply a preset back up file that is triggering the error?



http://advanced-post-list.wikiforum.net

3 Re: I get errors with the latest update on Sun Apr 15, 2012 6:45 am

GameDemon


Admin wrote:Sorry about the issue and thank you for posting this.

The problem seems to be showing up in the preset's post parents list. Either the variable is not an array or it isn't set. Sounds like its something in the preset backend settings.

Did you upgrade and then downgrade with any of the beta versions? ...and could you supply a preset back up file that is triggering the error?




Yes, I did upgrade. I'll try to do a fresh installation and see if it works.

4 Re: I get errors with the latest update on Sun Apr 15, 2012 6:48 am

Admin


Admin
I ment, did you upgrade to the beta version and then back to 0.2.0 at any point?

http://advanced-post-list.wikiforum.net

5 Re: I get errors with the latest update on Sun Apr 15, 2012 6:50 am

GameDemon


It's no good, I can't use the admin panel either.

6 Re: I get errors with the latest update on Sun Apr 15, 2012 6:50 am

GameDemon


Admin wrote:I ment, did you upgrade to the beta version and then back to 0.2.0 at any point?

I did, yeah, but, I think, only after I got those errors.

7 Re: I get errors with the latest update on Sun Apr 15, 2012 7:01 am

Admin


Admin
Hmm, that's a lil interesting. Didn't expect that. I'm might have to think about this one. Kinda wish I was able to debug that. Same errors as before?

http://advanced-post-list.wikiforum.net

8 Re: I get errors with the latest update on Sun Apr 15, 2012 7:07 am

GameDemon


Admin wrote:Hmm, that's a lil interesting. Didn't expect that. I'm might have to think about this one. Kinda wish I was able to debug that. Same errors as before?

Yes, I keep getting the same errors as before.

Do I need to send you anything?

9 Re: I get errors with the latest update on Sun Apr 15, 2012 7:27 am

Admin


Admin
Ok, this is probably one of the reasons I need to go back through and recode some things. I've already made plans reconstruct post types and taxonomies for the next beta. The admin page and the core file were designed separately and I haven't gone back through to match up or merge the functions. Might be grinding gears and broke the rest of the page, cause at the bottom of the small print should of continued with more of the settings page, except at normal font-size.

I would recommend reverting to Beta 2 if that version was working fine for you, and wait for Beta 4.

If you have a preset downloaded file that you can send that contains the errors and/or uses the post parent selector, then that would be nice. I'm just curious as to what type of values is being saved in _postParents and why it could be triggering these errors.

http://advanced-post-list.wikiforum.net

10 Re: I get errors with the latest update on Sun Apr 15, 2012 7:44 am

Admin


Admin
Its a lil aggravating seeing a working version bug up like this, but I knew it might of happened eventually. Sorry about the problem(s) though. Hopfully this doesn't effect you too much in a negative way.

Meanwhile, I'll be working on the functions that I recently designed, and fix some of the issues that I've seen reported.

http://advanced-post-list.wikiforum.net

11 Re: I get errors with the latest update on Sun Apr 15, 2012 8:35 am

GameDemon


Unfortunately, I have no other option but to wait for the newest version.

The previous version doesn't work with my new theme. It doesn't show any errors and the admin panel works fine, but I can't control the number of posts I want it to show (It's constantly stuck at eight posts max).

This was different, it showed me a whole list, if only it weren't for those errors...

I love this plugin so I'll be waiting patiently for an update and see if that works. Smile

Sponsored content


View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum